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Symbols used in the text
These paragraphs contain tips and practical advice for working with the 2D system

In the paragraphs highlighted with this symbol, you will find additional information and it is
very important that you follow the instructions given.

Documentation reference
 A user manual reference number is provided so the user can seek further assistance
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1 Desktop appearance
A typical Analyzer desktop mainly consists of 5 windows:


On top of the screen is the header bar with the main menu & toolbar.



At bottom of the screen is the Overview window in which certain signals (channels) of the
complete measurement are shown.



The biggest window centered on the screen is the Moving window. This window contains a
selected range of the signals.



The small Circuit window shows the track and the position on the track for the section currently
displayed in the Moving window.



The Quick bar at the right of the screen is
helpful for fast access to common functions.
These functions are user defined as any
main menu item may be selected to be
shown here. This window may be closed to
gain space on the screen.
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1.1

Main menu items









The File menu contains functions (analysis tools) to load and modify 2D measurement files
The Functions menu allows access to basic and advanced analysis tools
The View menu controls the layout of the Analyzer desktop
The Measurement menu contains commands to view the measurement(s) in different ways
The Settings menu contains functions to administrate both Analyzer and measurement settings
From the Wizards menu several Wizards may be run to achieve common tasks
Inside the Help menu, online help for the Analyzer software is available

1.1.1

The "File" item of the main menu























Load measurement of event: Shows a browser
of measurements inside the current event
Load measurement: Shows a browser of
measurements together with a directory tree
Load measurement by plugin: Loads a
measurement through an import plugin
Overlay lap: List of lap times of current
measurement to overlay another lap
Remove active measurement: Unloads the
currently active measurement
Exchange measurement: Replaces the active
measurement with another one which can be
selected in a browser
Reload: Forces reloading of the active
measurement to re-initialize it
Desktops: Save/load/delete desktop settings
GoogleEarth link: Creates a KLM file to use with
GoogleEarth
Load Reference lap: Load a previously saved
reference lap
Save as Reference lap: Save the current lap of
the active measurement as reference lap
Export: Exports measurement data partially or
completely in different formats
Live export: Create compressed .exe file
containing Analyzer together with measurement
Screen export: Exports visible channels inside
the current selection and compress them in a zip
Cut measurement: Trim off parts of the
measurement

Restore original lap times: restores recorded lap times
Restore original section triggers: restores recorded section triggers
Comment: Editor to quote (enter a comment of) the active measurement
View Spec: shows the measurement´s SpecSheet
0-9: History list of previously loaded measurement files
Exit: Terminates the Analyzer program
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1.1.2

The "Functions" item of the main menu


































Laps: Shows a window containing the lap times of the current
loaded measurements
Section times: List of section times of the current loaded
measurements
User defined markers: Shows a list of the measurement´s
user defined markers
Circuit: Small track map window with current selection
highlighted
Multi circuit: Starts a window with the GPS map on a Google
Earth background
Track mode: Detailed track map with inscription of channel
values
XY - Plot: 2-dimensional representation of the relation
between two channels
Min/max table: List of minimum, maximum and average
values of channels lap by lap
Histogram: Statistics of a channel with various split
conditions
Spectral analysis / FFT: Fast Fourier transformation analysis
of a channel
Data window: Define an additional data window
Status bits: function to “decode” status bits of channels
DIAG Bit Maps: Indicates a map of the used bits for diagnosis
Dynamic test: Start a dynamic test
Rainflow: The rainflow-counting algorithm (also known as the
“rain-flow counting method”) is used in the analysis of fatigue
data in order to reduce a spectrum of varying stress into a set
of simple stress reversals. Its importance is that it allows the
application of Miner's rule in order to assess the fatigue life of
a structure subject to complex loading.
Merge 2 measurements: combine two measurements to one
Video: Additional module for playing video
GPS: several functions for GPS lap and section triggers
Print report manager: Management and usage of printing
reports
Measurements: Channel settings editor
Active measurement: Set one of the loaded measurements
the active one
Swap measurements: Swaps the loaded measurements
Measurements visible: Toggle visibility of the channels of a
measurement inside the Moving window
Calculation files: Manage cal-files in different folders to run
the 2D CalcTool on
Run cal file (software folder): Show list of cal-files in Race
folder to run 2D CalcTool on

Run AutoCalc: Calculates all cal-files listed in the AutoCalc Configurator
Math files: Call the MatLab interface
Scripts: Starts a window to create/edit scripts
Run script: Shows a list of available scripts
Spec sheet: Run the SpecView program to show the spec sheets of the loaded measurements
Formula editor: Starts the formula editor
Screen shot: Takes a shot of the actual screen
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1.1.3

The main menu item "View"













Quick bar: Toggle visibility of the Quick bar which offers
access to common functions
Visible windows: Show list of currently opened Analyzer
windows
Windows full screen: Shows the moving window on full
screen
Reset window positions: restores the saved window
positions
Moving: shows different options for the moving window
Small borders/max info: switches to small borders to show a
maximum of information
Standard borders: switches to the standard borders
Templates: Shows a list of all available templates
White background scheme: Apply colors to currently opened
Analyzer windows with a white background color
Light background scheme: Apply colors to currently opened
Analyzer windows with a light background color

Dark background scheme: Apply colors to currently opened Analyzer windows with a dark
background color
Use template colors: Apply a color template to currently opened Analyzer windows



1.1.4

The main menu item "Measurement"

















Linked: Several loaded measurements are moved
together in the Moving window
Measure: Activate the measuring mode and show the
channel values at the mouse cursor position
Measure (active run): Special measuring mode which
shows only the active measurement in channel colors
Measure (active special): Very special measuring mode
which shows the active measurement in channel colors and
the other measurement in measurement colors
Distance plot: Show channel values curves over distance
in meters
Time plot: Show channel values curves over time in
seconds
Previous selection: Return to previous range selected in
the Moving window
Zoom: Editor to zoom in/out the selection visible in the
Moving window
Zoom full lap: Show the current complete lap in the
Moving window
Zoom full section: Show the current complete section in
the Moving window
Jump to lap start: Moves the selection to the start of the
current lap
Previous lap: Jump one lap back
Next lap: Jump one lap forward
Jump to fastest lap: moves the selection to the start of the
fastest lap

Synchronize: Align the other measurements to the active one to achieve the same lap position

2D Analyzer

page 8 / 82









1.1.5

Synchronize lap triggers: Temporarily adjust lap trigger offset to active measurement in case
of different lap trigger sender positions
Shift lap triggers by distance: Shifts the lap triggers by distance
Phases definition: Phases are used to filter data before applying a data analysis function. A
phase definition is a set of rules related to channel value, laps selection, distance or duration.
Show phases: display on the overview window in red the locations where the rules that defines
phases are fulfilled.
Go to previous phase: A phase is an uninterrupted portion of signal where the rules that define
phases are fulfilled. Go to the previous phase means going to the previous uninterrupted
portion of signal where the rules that define phases are fulfilled.
Go to next phase: see go to previous phase

The main menu item "Settings"




















2D Analyzer

Language: Select language from German, English, French,
Italian, Spain and Japanese
User management: Administration of separate user settings
with individual options and channel settings
Switch user: Option to switch the user, if you have the MultiUser functionality
Change password: Each user can supply a password which
will be prompted for at login
Special channels: Assignment of measured channels to
predefined functionalities
Track: Administration tools for the track of the current event
Video time shift: Offset of the video file to the start of the
measurement
Templates: Administration of the available templates
Track mode settings: Administration of the existing Track
mode setting files
XY-Plot settings: Administration of the existing XY-Plot
setting files
Min/max table settings: Administration of the existing
Min/max table setting files
Histogram settings: Administration of the existing Histogram
setting files
FFT settings: Administration of the existing Spectral
analysis/FFT setting files
Export settings: Administration of the existing Export setting
files
Print manager settings: Administration of the existing Print
manager setting files
Printer setup: Options of the currently active printer
Export of settings: Function to export settings of the current
user to import them somewhere else
Import of settings: Function to import user settings
Options: User defined options of the current user
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Special channels
Special channels are defined by assigning special meaning to recorded channels. There
are fixed and user defined special channels. Fixed channels are needed by Analyzer whilst
both types may be used in cal-files by typing the @ identifier.

Fixed special channels: Analyzer needs information about certain channels for example to calculate
the distance from speed or feed the chassis module.
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User defined special channels: Assignment of recorded channel to a free defined special channel.

Track



Assign track map

Choose the correct track map to your event.
2D Analyzer
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Track settings

Dialog to manage event specific track settings
Calculate GPS map if available: If checked the software will look for channels named "Longitude" and
"Latitude", and -if available- generate the track map from them. To filter out invalid GPS data a channel
named "GPSValid" will be used to mark the valid data (0=invalid, 1=valid).
Event measured on a closed circuit: If checked all lap-specific logic will be applied like LapChecker
wizard, offset detection, segment detection.
Track length & tolerance: Laps whose lap length (= integrated speed) differs more than the |Tolerance|
are treated as invalid or incomplete laps.
Track mode markers: Settings for markers
Markers whose position differs at most from the "Marker meter range" value are placed at the same
position than the driver.
The "Min segment distance" determines whatever marker are created or not. Min/max markers which
are closer to the segment edge than the "Min segment distance" value are not created.


Sections

Overview of the section times of each loaded measurement lap by lap. The sum of the best section
times gives an idea of a possible ideal lap time.


Track segments

Editor to manage the track segments (straights and corners) of the current event. Track segments
normally are detected and inserted automatically. Segment names may be edited by the user.
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Detect track segments

Track segments are detected and saved automatically each time when the fastest lap time of a loaded
measurement is more than 3 seconds faster than the previous one on which segments have been
detected. This feature shall ensure correct straight and corner detection when track conditions like
weather have changed substantially.
Running this function manually will cause re-detecting segments. This is useful if the segments list
obtained automatically is not valid or inaccurate. If the detection did not find all desired segments the
user can insert or modify them manually in the track segments editor or in the Moving window.


User defined markers

User defined marker can be set by a left click on the Details windows (Moving window)

Select the menu item Add to Add a user defined marker.
User define markers can be managed (deleted or their name changed) from the main menu Function ⇒
User defined markers

1.1.6

The main menu item "Wizards"






2D Analyzer

Gear calculation: Calculates a gear channel out of RPM and speed
or using a gear box sensor channel
Create track map: Generates track map out of either speed + lateral
acceleration or GPS coordinates
Detect track segments: Automatic track segment detection
Tire perimeter: Wizard to recalculate speed by changing tire
perimeter and/or impulses
Lap checker: Wizard to check track length and lap triggers
page 13 / 82

1.1.7

The main menu item “Plugins”









1.1.8

2D Text reader: ASCII/CSV import
2D Excel reader: Excel import
2D RPC III reader: RPC 3 import
2D Filters (#selectedChannel): filter function for the selected
channel
2D External Functions: online mathematical channel calculation
2D Utilities: additional tools
2D Video Functions: function to link a video to the measurement
2D Track channels: creation of segments by channel data

The main menu item “Tutorials”







1.1.9

The main menu item "Help"










1.2







Save current desktop layout: Shows how to store a template
containing the current windows
Show measured data over distance: Shows how to switch
to distance plot
Perform grouping of channels: Guide to managing and
showing channel groups
Show Time Diff (win or loss): Explanation how to display
win/loss channel
Display a Track mode: Guide for displaying a detailed track
map
Show phases in Moving window: Explanation how to setup
and highlight logical phases

Help: Show online help about the 2D software modules
Shortcut keys: List of available keys in the Analyzer
Show hints: Show Tips close to mouse cursor in certain
windows
What's new ?: List of changes since the last software version
Glossary: Index of common used terms
FAQ: List of frequently asked questions with answers and tips
2D-Datarecording Homepage: Opens Internet browser with
the 2D homepage
Mail to 2D-Datarecording: Opens the mail client with an
empty mail to 2D
About: Shows a version and system info window

Toolbar buttons
File functions are functions to load and modify 2D measurement files
Basic analysis functions include Moving and Overview windows and lap times
Advanced analysis functions include Track mode, XY-Plot and Min/max table
Visibility of channels in the Moving window can be switched individually, group wise or via areas
Other functions accessible via toolbar buttons are Window list, Options Dialog and Templates
The measurement functions include commands to view the measurement(s) in different ways
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1.2.1

File functions

Load measurement: Shows browser of measurements together with a directory tree
Overlay lap: List of lap times of current measurement to overlay another lap
Remove active measurement: Unloads the currently active measurement
Exchange measurement: Replaces the active measurement with another that can be
selected in a browser
Reload: Forces reloading of the active measurement to re-initialize it

1.2.2

Basic analysis

Overview: Shows the Overview window of the active measurement
Moving: Shows and activates the Moving window
Laps: Shows a window containing the lap times of the current loaded measurements
MultiCircuit:

1.2.3

Advanced analysis

Track mode: Detailed track map with a graphical display of channel values through color
variations
XY-Plot: 2-dimensional representation of the relationship of two channels
Min/max table: List of minimum, maximum and average values of channel lap by lap
Histogram management
FFT management

1.2.4

Channel visibility

Channel settings editor / Switching of the visibility of channels in the Moving window
Channel group editor / Switching of the visibility of channel groups in the Moving window
Switching of the visibility of areas containing channel groups in the Moving window

1.2.5

Other functions

Window list: Toggle visibility of the Window list which offers access to common
functions
Options: User defined options of the current user
Templates: List of available Analyzer desktop schemes with a function to save the
current desktop
2D Analyzer
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1.2.6

Measurement Functions

Linked: Several loaded measurements are moved together in the Moving window
Measure: Start/stop measuring mode to show the channel values at the mouse cursor
position
Distance plot: Show channel values curves over distance in meters
Time plot: Show channel values curves over time in seconds
Previous selection: Show previous selection in Moving window
Zoom: Editor to zoom in/out the selection of the time/distance range for which the signals are
displayed in the Moving window
Zoom full lap: Show the current complete lap in the Moving window
Jump to fastest lap: Move the selection into the fastest lap of the measurement
Previous lap: Jump one lap back
Next lap: Jump one lap forward
Synchronize: Align the other measurements to the active one to achieve the same lap
position
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2 Program modules
2.1

Overview window

Quick overview of complete measurement
Each loaded measurement in Analyzer is displayed in a separate Overview window. In the Overview
window the measured values of certain channels are shown. The position of the lap triggers (vertical
lines) are also displayed. Below the lines slightly at the right, the lap numbers are indicated. The lap
trigger is the position where the lap start.
The position of the time interval selection in the Overview window of the signals visible in the Moving
window is marked inside the Overview window by a rectangle. You can move this rectangle with the
mouse easily. If you press the <Ctrl> key simultaneously you can change the size of the rectangle - so
will see a higher fragment inside the moving window of the current measurement.

2.1.1

Functions accessible by right clicking
Print






The standard Print function simply prints the content of the selected window.
The Print via Excel function embedded the selected window into a chosen Excel sheet together
with data from SpecSheet. This updated Excel sheet may be printed out directly or with a preview
before.
Print via Print manager open a windows with additional printing options.
Before printing the background color of the window changes to white color to save printer
ink. This option can be changed in the Analyzer Options Dialog.

2.1.2

Properties

The properties editor includes options for changing how the Lap triggers, Segments, Sections and the
Color scheme of the window look like.
The properties are stored in the current Template which may be saved to disk to make the modifications
permanent.
The color page in the properties editor is only available when template colors are used.

2D Analyzer
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2.1.3

Keys
Shortcut / Mouse
Mouse: Left button
Mouse: Double click
<1> – <9>
<ALT> + <1> - <ALT> + <9>
<CTRL> + <HOME>
<SHIFT> + <HOME>
<F11>

2.2

Action
Offset moving
Activate moving window
Activate measurement
Show overview
Fastest lap
Entire lap
Maximum / Restore window size

Moving window

Precise comparison of several measurements including measuring functions
All loaded measurements in Analyzer are displayed together in the Moving window. In contrast to the
Overview windows, the Moving window is able to show a zoomed in part of the measurement. This
allows precise overlaying of measurements for comparison purposes.
The interval for which the signals are displayed in the Moving window is visualized through
a rectangle in the Overview windows.

2.2.1

Functions accessible by right clicking
Add area

The Moving window can be split vertically to display additional sub windows (areas) which each contains
channels of another group. The sub window can be suppressed by right clicking and selecting the Edit
area menu item.
The visible areas are stored inside the current Template.
Measuring mode
A functionality of the Analyzer which shows physical values of channels at the mouse position in a small
extra window.

Available are 3 fundamental different measuring modes:




Channel local measuring mode <Measure> menu item
A click on <Measure> menu item displays the channel data at a given time in the same colors
as in normal Moving mode.
It is started with mouse double click in the Moving window or <Space> key. It is stopped with
mouse double click in the Moving window or <Space> key or <Esc> key.
Local values determination of active measurement <Measure (active run)> menu item
A click on <Measure (active run)> displays only the channel values of the active measurement
in the individual channel colors.

2D Analyzer
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It is started with <Enter> key and is stopped with mouse double click in the Moving window or
<Enter> key or <Esc> key.
Extended local value determination of the active measurement <Measure (active run)>
menu item
A click on <Measure (active run)> displays the channel curves of the active measurement in the
individual channel colors along with the other measurement channels values in their colors.
It is started with <Shift> + <Enter> key. It is stopped with mouse double click in the Moving
window or <Shift> + <Enter> key or <Esc> key.

During the local measuring mode all Analyzer functions are available, i.e. it is possible to change the
selection, to load or remove a measurement.
The local values window shows the measured value of each channel at the mouse position.
Either the values of the visible channels or the values of all channels are shown. You can toggle both
modes by clicking on the black double arrow in the upper left cell.
With more than one measurement loaded there is a function to show not only the absolute physical
channel values but the relative channel values of the other measurements compared to the first
measurement. You can toggle both modes by clicking on the black triangle symbol on the left in the
second row.
Clicking on a channel name as well as double clicking a measured value toggles the
visibility of the channel. Clicking a measured value makes this channel active. Holding down
the mouse button lets the channel's curve blink inside the Moving window to help
identification.
Print
The standard print function simply prints the content of the selected window.
The Print via Excel function embedded the selected window into a chosen Excel sheet together with
data from the SpecSheet. This updated Excel sheet may be printed out directly or with a preview before.
Print via print manager starts a window with additional printing options.
Before printing the background color of the window changes to white color to save printer
ink. This option can be controlled in the Analyzer Options Dialog.

Visibility of measurements
A loaded measurement can be made invisible. This helps focusing on another, visible measurement in
the Moving window. Measurement m is made invisible by pressing <Ctrl> + <M> where “M” stands for
the measurement number.
Example:
2 measurements are loaded. In the Moving window all channels of measurement 1 are red, all channels
of measurement 2 are blue. Now measurement 2 is made invisible (<Ctrl> + <2>). The channels of the
remaining visible measurement 1 are displayed in their individual channel colors. Pressing <Ctrl> + <2>
once again makes measurement 2 visible again to show both measurements in their measurement
colors.

2.2.2

Properties editor

The properties editor (<Ctrl> + <P>) includes options for changing how the lap triggers, segments,
sections and the color scheme of the window look like.
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The properties are stored in the current Template which may be saved to disk to make the
modifications permanent.
The tab “Colors” in the properties editor is only available when template colors are used.

2.2.3

Channel colors

The color editors of measurement can be accessed by pressing <F9> or from the main menu (Settings
⇒ Options).
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With one measurement visible, the channel curves are displayed in their individual channel colors. When
several measurements are visible in the Moving window then each measurement's channels are
displayed in the measurement's color, e.g. measurement 1 is red, 2 is blue and so on.

2.2.4

Keys

Shortcut / Mouse
Mouse: Left button
Mouse: Double click
<s>
<t>
<1> – <9>
<ALT> + <1> - <ALT> + <9>
<CTRL> + <HOME>
<SHIFT> + <HOME>
<F11>
- MOVING MODE <SPACE>
<ENTER>
<SHIFT> + <ENTER>
- MEASURING MODE Mouse: Left button
Mouse: <CTRL> + left button
Mouse: Left button in measuring values
Mouse: Left button on channel name in measuring values
Cursor left / right
<CTRL> + cursor left
<CTRL> + cursor right
<SPACE>
<ESC>
< or >

2.2.5

Action
Offset moving
Start measuring mode
Change to Distance plot
Change to Time plot
Activate a measurement
Show overview
Fastest lap
Entire lap
Maximum / Restore window size
Start measuring mode (all)
Start measuring mode (active run)
Start special measuring mode
Set marker
Choose active channel
Choose active channel
Toggle channel’ s visibility
Scroll through time or position
Set left marker
Set right marker
Stop measuring mode
Stop measuring mode
Toggle active channel

Examples

The following are some ‘step-by-step’ instructions to help new 2D users to master some common
operations in the Analyzer software. Most of these can also be found in the context-sensitive help files,
but here we can go into a little more detail.
Rate of Change Measurement – to individually check the amount of change in a channel over a
specific time.
This function is often used to check deceleration rate on braking (V_Front over time), front or rear
suspension piston speed (F_Sus or R_Sus over time). In this example, we will check the rear shock
piston speed, so we can determine the piston speed range to make the appropriate damping
adjustments:




Load the rear suspension channel in Analyzer screen; Main menu item "Functions / Measurement
/ Channel" or "Channels" icon in toolbar or shortcut "Alt + U", and then Left-click on the channel
name to select the rear suspension channel (called Rear Shock, in this example using the Bike.97
demo data).
In Moving Mode (the default mode when you first open Analyzer), move the Analyzer screen view
to the point on the track you are interested in (move it with Up – Down or Left – Right arrow keys
or L-click-and-drag with the mouse). In the example we have chosen the first chicane after the
start-finish on the fastest lap (choose fastest lap by clicking on the "Trophy" icon on the toolbar).
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Start the Measuring Mode by pressing the "Space bar" or main menu item "Measurement /
Measure" or "Measure" icon in toolbar. The screen has gridlines and a cursor now, and remember
that the last channel you loaded (in this case, Rear Shock) is the one that the cursor will follow. If
you want the cursor to follow another channel, Left-click once on the numerical value displayed
for that channel in the small pop-up Measuring Values window (careful! L-click on the channel
name removes that channel from the screen).
Choose the area you are interested in and use the mouse or Left – Right arrow keys to place the
cursor on the appropriate point of the graph and L-click. In the example we are concerned about
the rear rebound speed as the bike changes direction. So the cursor is positioned on the peak
just before the rear suspension becomes almost fully extended, and then L-click once – which will
display a vertical line through that point, with the Rear Shock channel value written near the
bottom (in this case, 21.9 mm). See the next figure below.

Rate of change measurement: Selection of the starting point.
Move the cursor to the next minimum peak and L-click again. The two points you clicked are displayed
with vertical lines through them and their values noted on the bottom of the screen (in this case 21.9 mm
and 0.2 mm). See the next figure below.

Rate of change measurement: Selection of the ending point.
2D Analyzer

page 22 / 82



Along the top of the screen is displayed the channel name, the time interval between the two
points, the distance between the two points, and d/dt which is the average speed over that
distance, in mm/sec. That is, Rear Shock speed at that point. So, in our example the channel
Rear Shock has moved a distance of -21.69 mm over 0.403 sec, giving an average shock piston
speed of –53.89 mm/sec for that movement. Note that the Shock distance and speed are
negative numbers because we are measuring in the rebound direction.

Maybe the original problem we were looking at was the difficulty in changing direction at this chicane,
and from this data we conclude that this rebound speed is too slow, making the bike pitch too slowly.
So we want to adjust the rear rebound damping, and now we can refer to the damping charts knowing
which speed range to make the adjustments in.
Please ensure that you are dealing with the same units when referring to your suspension damping
charts; many damping charts are in m/sec, whereas the Analyzer measure mode numbers above are in
mm/sec; the rebound speed shown here of –53.89 mm/sec will often be shown on a damping chart as
0.054 m/sec.
Also understand that this is one specific measurement only, you should be checking many points on
many laps before coming to a conclusion about adjustments.

2.3

Circuit

Map of track with information about current selection
The circuit window shows the track map with the current selection of the active measurement
highlighted. The circuit window is displayed or hidden by pressing <C> or from the main menu (Functions
⇒ Circuit).

2.3.1

Functions related to the circuit window
You can start all functions from the context menu. To show this menu, click with the right
mouse button at the small circuit window (default: right bottom corner)



Assignment of track map to the current event

Choose the track map for your event.
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Create track map

Generates a new track map out of either speed + lateral acceleration information or the GPS coordinates


Track settings

Dialog to manage event specific track settings
Calculate GPS map if available: If checked the software will look for channels named "Longitude" and
"Latitude", and if they are available generate the track map from them. To filter out invalid GPS data a
channel named "GPSValid" is used (0=invalid, 1=valid).
Event measured on a closed circuit: If checked all lap-specific logic will be applied such as LapChecker
wizard, offset detection, segment detection.
Track length & tolerance: Laps whose lap length (= integrated speed) differ more than |Tolerance|
compare to the Track length are treated as invalid or incomplete laps.
Track mode markers: Control the position of markers in the track map
Marker meter range: Markers whose position differs at most this value from user position are placed to
the same position
Min segment distance: Min/max markers which are closer than this value to the segment edge are not
created
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Export and printout

The Circuit map graphic may be exported and printed in several ways:





2.3.2

Clipboard: Circuit is copied in Windows Clipboard using EMF vector format
Export as Enhanced Meta File: Circuit is saved to disk in EMF vector format
Print: High-quality print fitting the print page with circuit inner/outer line
Print via Print manager: Fully-featured print layout module

Properties

The Circuit window's editable properties include selecting the color of the background, track, selection,
sections, etc.
The size of the position circles inside the Circuit window can be adjusted in addition.

Options for displaying start/finish flag, segment, borders and corner numbers are also set
in this windows.

2.4

Channels

Editor of channel settings
The channel editor is accessible from the main menu under Function ⇒ Measurement ⇒ Channels. Each
sensor whose data have been downloaded results in a channel in the current measurement.
Additional channels can be calculated by using calculation files (*.cal).
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The Analyzer adds virtual channels which are calculated from channel containing measured
values. Each channel has its own settings which can be edited. Channels can be grouped.
For example a group of channels can be assigned to the engine, or the suspensions.

2.4.1

Editable settings in the table of the channel editor

Table column
Visibility
Scaling
Color
Limits
Autoscale for limit
Dynamic autoscale for limits
Format
Reduce in Overview
All in Moving
Key
Zero ruler
Color scale
Group assignment

Function
Switch channels on/off
Show scaling beside the channel curves
Individual channel color
Lower and upper limits for physical channel values
Automatic calculation of suitable limits
Limits are calculated depending on selection in Moving window
Number of digits after decimal separator
Type of data reduction of several measured values into one value
All measured values are displayed graphically
Short key to switch a channel's visibility
Horizontal line at physical 0 position
Mapping of physical values onto colors in defined steps
Collection of channels in topics

Additional channel dependent settings found by double clicking in the tab “Ruler/Alarm”.
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2.4.2

Groups
Channels can be organized (collected) in groups which each represent one topic.
The group names may be edited freely. The channels inside the first group will be shown
at Analyzer program start.

Examples:





A channel “Speed” may be assigned to many groups like “Start”, “Engine”, “Suspension” and
“Time Diff”.
A channel “Spring” may be assigned to group “Suspension” only.
A group “Engine” may contain channels like “Speed”, “RPM”, “Throttle” etc.
A group “Temperature” may contain “RPM”, “OilTemp”, “WaterTemp” etc.

By switching on/off a group all channels assigned to this group are switched on/off.
Each group may be assigned a short key to switch its visibility in the details windows fast.
By in the tab Groups of the Channel Editor, the visibility of a group of channels can be turned on/off by
clicking in the column with the name Visible.
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2.4.3

Functions

There are several functions to manage the channels list conveniently:
The Speed search edit field allows searching for channels with a defined name mask. For example,
typing “V_” finds all channels with names starting with “V_”. Typing “*susp” or “?susp” finds all channels
which names contain the string “susp”.
To display all channels with a certain channel type like “Digital” select the appropriate channel type.
A click on the title of a column sorts the channels in ascending/descending order using field this column.
This works for the columns where sorting makes sense, e.g. number, name or frequency etc.
By clicking on the button “Sort group” on the bottom right of the channel editor, it is possible to insert a
column containing the name of a group. By sorting this column it is possible to change the settings of
the channels belonging to this group very easily.

2.5

Lap times

These information are accessible from the Main menu Function ⇒ Laps (first menu item).
Table with lap times of all loaded measurements.
The first tab of the Laps window shows a list of the lap times of each loaded measurement.
Every loaded measurement has also its own tab with detail information about the lap length in meters
and start/end of the laps (in meters).

A lap which appears to be invalid is light greyed to set it apart from valid laps in which the lap length fits
the defined track length.

Manually inserted laps are underlined

2.5.1

Functions
By clicking on a table entry the selection of the clicked measurement is set to the
corresponding lap.
A not-wanted lap may be removed via context menu or with "Del" key. Be careful with that
function as the chosen lap trigger will disappear.
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2.6

Section times

Table with section times of a measurement

The sum of the best section times gives an idea of a possible ideal lap time.

By using the delta button, you´ll get the section time´s delta (and, if available, distance delta) compared
to the best section time.

2.6.1

Definition of Sections

This function is accessible by clicking on the button on the bottom right of the section times window.
The track may be divided into up to 6 sections which are defined by a distance from
start/finish line. Each section can be named.
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2.6.2

Functions

Print
This function is accessible by right clicking on the panel.
The print function simply prints the content of the current section times window. The "Print all section
tables" function opens one section times window for each loaded measurement and prints their content
using Notepad.

2.7

Min-/Max tables

Overview of lower, upper and average values of channels
A Min/max table serves as a quick overview of minimum, maximum and average values of some
channels of a measurement lap by lap.
This function is accessible from the main menu Function ⇒ Min/Max table.

2.7.1

Creation and setup

A Min/max table setting can be created and saved to disk to be reused later.
You can create a new Min/max table or edit an existing setting via the shortcut <Alt> + <M>

Phases
Without using phases the min/max/avg values of each channel are displayed lap by lap. With the use of
phases, the channel values are calculated per lap where the phases apply. Phases are filters with many
options.
Channels
Each channel may be selected to be analyzed inside a Min/max table. For each chosen channel it is
possible to select minimum, maximum and/or average value. Additionally a filter value can be provided
to apply an average filter to the channel.
You will get detailed information about the creation of a new Min/Max tables in the examples
below.

2.7.2

Management

The saved Min/max table settings can be overridden from inside the Min/Max window by clicking on the
channels button. The phases condition can also be edited by clicking on the phases button.

2.7.3

Functions

Exports
The contents of the table may be exported in ASCII or Microsoft Excel readable format.
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Find position
By clicking on a minimum or maximum value of a channel the corresponding position in the
measurement is selected and centered inside the Moving window. If the channel was not visible it will
be switched on and activated in the Moving window.
Print
The print function simply prints the content of the current Min/max table.

2.7.4

Properties

The only property of a Min/max table is the choice to hide the button bar. This option is accessed through
the context menu (right click).

2.7.5

Examples
Example 1

A Min/max table called "Speeds" containing minimum, maximum and average values of channels
"V_Front" and "V_Rear" and minimum and maximum values of channel "RPM" will be created.
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Example 2
A min/max table called "Deto" containing maximum and average values of detonation channel
associated with a 2-stroke engine will be created.
Additionally a phase condition will be set which defines phases where the throttle channel has values of
at least 30 %.

2.8

Track mode

Graphical presentation of track with channel values at defined positions
A window with a graphical representation of the track with channel values at defined positions. A 3rd
dimension is achieved by using a so-called color channel.
This function is accessible from the main menu Function ⇒ Track mode
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2.8.1

Creation and setup

A colorized track can be created and saved to disk to re-use it later. The creation of a colorized track is
parametrized through two main option groups: The settings concerning the graphical layout of the track
and the type of the visible markers.
You can create a new colorized track or edit an existing setting via the shortcut <X>

Marker settings
The settings window is accessed by right clicking on the colorized map and select the first menu item
(Settings) in the context menu.
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At certain positions on the track markers are placed containing channel values at these positions. The
calculation of the channel values depends on the marker type which can be:








lap
sections
corners
straights
user defined
start of phases
end of phases

This window is accessed by clicking on the tab
“Corner” of the settings window in track mode.

All markers of a certain type have options like text font, additional inscription of channel's dimensions,
display of a legend etc. These settings can be changed on the tab “Corners” below.

By clicking on the name of the channel in the table of the tab “Corner” the following window is shown:
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Additional channel that will become markers on the track can be added to this table at the right of the
window.
A marker of type lap/sections/corners or straights may contain the minimum, maximum or average value
of channels or the value at the minimum/maximum of another displayed channel.
The function (minimum, maximum, average…) which value is display at the location of the marker on
the track is selected by clicking on the type of the channel. The following window appears and enables
to change the function to apply to the value at the marker position.

A marker of type user defined/start of phases or end of phases contains channel values at this defined
point.

Graphic settings
The graphic settings are accessed by selecting the tab General and Layout. These tabs control the
appearance of the track map. The color channel may apply to the existing sections, the segments or a
measured channel. When a real measured color channel is selected, its color scale defines the mapping
of the measured values to colors.
The visibility of the graphic symbols for the lap trigger, the sections, the segments etc. can be selected
on the panel of the Layout tab. The drawing type of the track (pixels, lines, circles or crosses) is selected
on the window shown by clicking on the button Draw type. The track width is also adjustable on this
panel.
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2.8.2

Functions
Print






The standard print function simply prints the content of the selected window.
The Print via Excel function embedded the selected window into a chosen Excel sheet together
with data out of the SpecSheet. This updated Excel sheet may be printed out directly or with a
preview before.
Print via Print manager opens a window with additional printing options.
Before printing the background color of the window changes to white color to save printer
ink. This option can be controlled in the Analyzer options dialog.

Lap report
This function is accessed by right clicking on the colorized track map.
The lap report creates a table out of the Track mode settings which contain the channel values of each
marker of the Track mode (colorized track map) lap by lap.
The content of the lap report window can be printed by the print function.
The “Print via Notepad” function embeds the complete lap report table into a text file and prints it.
The lap report table may be exported to a Microsoft Excel (*.xls) file.

2.8.3

Management

The name of the file containing the settings of the colorized track may be renamed or deleted inside the
management editor that is accessed from the main menu Functions ⇒ Track mode ⇒ manage settings.
The editor shows also the name of the used Phase settings files.
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2.8.4

Examples
Example 1

The objective is to build a track which the settings file name is "Segments" that does not contain markers
and uses the sections as color channel.
Go in the Main menu, select Track mode ⇒ Create new.
Enter the name of the file that will contains the settings of the track.
In the settings windows add "Segments only" in the entry field Comment.

Example 2
The objective is to build a track colorized using the values of the “Speed” channel. The markers will be
of type corners with the minimum value of channel “Speed”.
Go in the Main menu, select Track mode ⇒ Create new.
Enter the name of the file that will contains the settings of the track.
In the settings windows add “Speed only” in the entry field Comment.
In the panel area labelled visible markers, check lap and corners and click <OK>.
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Example 3
The objective is to build a track colorized with the value of the channel “Throttle”. The name of the file
containing settings will be “Top speed”. The markers will be of type straights with the maximum value of
channel “Speed” and the RPM value at top speed.
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2.9

XY-Plot

2-dimensional presentation of relationship of 2 channels
Function to display a 2-dimensional graphical presentation of the relationship of 2 channels. A 3rd
dimension is achieved by selecting a color channel.

2.9.1

Creation and Setup

An XY-Plot setting can be created and saved to disk for later re-use.
You can create a new XY-Plot or edit an existing setting via the shortcut <Alt> + <F5> or from the main
menu:

You simply enter a name for the XY plot settings file and afterwards you select the plot´s settings.
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Settings
A XY Plot can graphically show the relationship of one selectable channel (X) to several
other (Y) selectable channels. In this case several XY-Plot are created. The data for the XY
plot can come from one or more measurements.
With the use of phases the displayed data can be filtered to a data subset. The color channel defines
the mapping of the measured values to colors. Alternatively, the color of the plot may be controlled/sort
out by measurements or by laps. Points (pixels), lines, circles or crosses can be selected to create the
XY plot (draw type). Thickness of the drawing elements are adjustable. Phases and draw types can be
changed through the context menu (right click) in the XY plot.

2.9.2

Functions
Limits

The lower and upper limits of X and Y channel in an XY plot window can be set in different ways. Limits
can be set manually via context menu.
With the toolbar at the top of the XY plot panel, the plot can be moved or zoomed in and out.

The catch function calculates suitable limits to display all graphic items in the window. The dynamic
auto-position function performs catching automatically when the XY plot data are continuously changing,
for example the selection windows is moved. The data of the XY plot will be actualized continuously, by
selecting the option current selection in the group laps/selection of the phases window.
Grid
The grid consists of regular horizontal and vertical lines. This helps for reading the values.
Print





The standard print function simply prints the content of the selected window.
The Print via Excel function embedded the selected window into a chosen Excel sheet together
with data out of the SpecSheet. This updated Excel sheet may be printed out directly or with a
preview before.
Print via Print manager opens a window with additional printing options.
Before printing the background color of the window changes to white color to save printer
ink. This option can be controlled in the Analyzer options dialog.

2.9.3

Management

The name of the file containing the settings of the XY plot may be renamed or deleted inside the
management editor that is accessed from the main menu Functions ⇒ XY-Plot ⇒ manage settings. The
editor shows also the name of the used phase settings files. The quickest way to open the editor is to
use the shortcut key <ALT> + <F5>.
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2.9.4

Properties

This panel is accessed by selecting “Properties” in the context menu (right click on the XY plot). The
option "Highlight phases with mouse" affects the reaction of a XY plot window when moving the mouse
over it. If several phases are defined in the Phase condition panel, then all graphic items belonging to
the same phase as the item under the mouse are highlighted.

2.9.5

Examples
Example 1

A XY plot named “Gear ratio” will be created, which shows the channel “RPM” vs. channels “V_Front”
and “V_Rear”.
“Throttle” will be used as color channel. A phase condition (L) of type “Laps/selection” ⇒ “Current
selection” with option “Follow selection” will be defined to show the gear ratio of the current selection in
the moving window.
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Example 2
Examine 2-stroke detonation by showing channels “RPM” vs. “Deto” with color channel “Throttle”.
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Example 3
Examine 2-stroke detonation for two different engine settings or laps. The XY plot shows “RPM” vs.
“Deto” of two loaded measurements. The colors option “by measurement files” is selected to distinguish
both measurements.

2.10 Histogram
Distribution for channel values.
A histogram is a graphical representation of the distribution of numerical data of a channel. It is an
estimate of the probability distribution of a channel data considered as a continuous variable. To
construct a histogram, the first step performed by 2D software is to “bin” the range of values of the
selected channel - that is, divide the entire range of values into a series of intervals - and then count
how many values fall into each interval. The bins are usually specified as consecutive, non-overlapping
intervals of a variable. The result is a frequency of occurrence (~ a probability) for the instantaneous
value of a channel to fall in one specific bin.
2D Analyzer

page 43 / 82

2.10.1 Creation and setup
A Histogram setting can be created and saved to disk for later re-use.
You can create a new Histogram or edit an existing setting via the shortcut <Alt> + <F1> or from the
main menu:

You simply enter a name for the Histogram settings file and afterwards you define the Histogram´s
settings.

Settings
The Analyzer software provides two ways to filter the data that makes histograms. The first is using the
concept of phases. The second is using the concept of “split channel”. The concept of phases is specific
to 2D Datarecording and used thoroughly for almost all analysis function of the Analyzer. Phases are
applied to a single channel, the one used to create the bins of the Histogram. Phases reduce the amount
of data of the channel entering in the creation of the Histogram to a subset. Options from the data filtering
are for example by lap/selection, time or distance range, or channel value range. The concept of “split
channel” is also particular to 2D Datarecording. The splitting channel can be considered as the channel
used to create the bins for the second dimension of a 3 dimensional histogram. Nevertheless, in the
histogram module the histogram will be “split” into as many histogram as the number of bin created by
the “split channel”. Take note that true 3 dimensional histograms can be created from the main menu
Plugins ⇒ 2D External Function ⇒ XYZ-Plot. An alternative to the creation of multiples histogram are
stacked histogram. Creation of stacked histogram is also possible with 2D software within the histogram
module.
The window showing options for creating histogram is shown just after having entered the name of the
histogram or by right clicking on an existing histogram.
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Options are grouped by functionality. A list of these groups and a short description of the groups
functionality is shown below:
Expression

Meaning

Channel

Choose your histogram channel

Horizontal scaling

Choose channel value range and number of subdivision for creating the
bins

Vertical scaling

Select auto limits or choose manual scaling

Phases

Restrict the data amount by phases

Files

Select the files you want to display

Split channel

Create multiple histograms using the split channel

Split phases

Divide diagrams or series by single phase conditions

2.10.2 Functions
Export
The contents of the table may be exported in ASCII or Microsoft Excel format.
Print
The print function prints the content of one or all Histogram windows. When printing several windows,
the layout of the printout can be managed.
Print via Print manager opens a window with additional printing options.

2.10.3 Management
The name of the file containing the settings of the histogram may be renamed or deleted inside the
management editor that is accessed from the main menu Functions ⇒ Histogram ⇒ manage settings.
The editor shows also the name of the used Phase settings files.
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The quickest way to open the editor is to use the shortcut key <Alt> + <F1>. Afterwards select the menu
item “Manage settings”

2.10.4 Properties
The histogram properties include many graphical options for tuning the visual appearance of the
histogram.
The presentation may be 2- or 3-dimensional, where various geometric options may be set.
To access the histogram properties dialog use the context menu (right mouse click) in an
opened histogram. The histogram appearance is controlled using “Graphics settings”. The
View3D options on the diagram tab and area series type on the series tab can be selected
to create 3 dimensional histograms.

The type of the series can be Lines, Areas, Points, Bars or Pie
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2.10.5 Examples
Example1
Simply show the overall distribution of RPM: channel “RPM” is selected, no phases are used, and active
measurement is selected. No splitting of diagrams nor data.




Start the analysis tool and enter the menu item Functions ⇒ Histogram ⇒ Create new. You can
also use the shortcut key <ALT> + <F1>.
Enter a name for the new Histogram, for example “RPM”
Select the following options as shown in the settings panel below:



Select the button <OK>. Afterwards you will see the following result
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Example 2
In this example you will make a comparison of throttle usage of two riders. Channel “Throttle” will be
selected, the phases cover the fastest lap, both measurements will be selected. The diagrams or
alternatively the data will be split by measurements.
Additionally a split channel (e.g. “Speed”) or split phase conditions will be used to examine throttle usage
in certain ranges of speed.




Start the analysis tool and click on the menu item Functions ⇒ Histogram ⇒ Create new. You
can also use the shortcut key <ALT> + <F1>.
Enter a name for the new Histogram, for example “Throttle_Hist”.
Select the following options in the settings panel.



Select the button <OK>. Afterwards you will see the following result.
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2.11 FFT (Fast Fourier Transformation)
Graphical output of the spectral analysis of a channel.
A fast Fourier transform (FFT) algorithm computes the discrete Fourier transform (DFT) of a sequence,
or its inverse. Fourier analysis converts a signal from its original domain (often time or space) to a
representation in the frequency domain and vice versa.

2.11.1 Creation and setup
A FFT setting can be created and saved to disk to be re-used later. This function is accessible from the
main menu Functions ⇒ Spectral analysis/FFT (Alt+F3) ⇒ Create new
Settings
After having entered a name for the new chart (see creation of a new FFT analysis above), the following
panel will be displayed:

Most of the options presented in this panel do need explanation. We will give only explanation for these
that need a background knowledge.
The data source can be single, sum or waterfall:




Single: One series of measured values
Sum: Average of several series of measured values
Waterfall: Several series of measured values displayed as a waterfall diagram

The FFT Depth controls the number of measured values to be analyzed. Higher bit depth means
narrower bins.
The Window type (windowing) controls the handling of each data series prior to calculation
You can minimize the effects of performing an FFT over a non-integer number of cycles
by using a technique called windowing. Windowing reduces the amplitude of the
discontinuities at the boundaries of each finite sequence acquired by the digitizer.
Windowing consists of multiplying the time record by a finite-length window with an
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amplitude that varies smoothly and gradually toward zero at the edges. This makes the
endpoints of the waveform meet and, therefore, results in a continuous waveform without
sharp transitions. This technique is also referred to as applying a window.
The Average function and Magnitude/Power spectrum apply to the calculated FFT data
dB display affects how the spectral analysis is scaled on the Y-axis
The amplitude and frequency range can be calculated automatically or set manually

2.11.2 Functions
Export
The FFT diagram may be exported in Windows Meta File format which can be imported e.g. in Microsoft
Word.
Print





The standard print function simply prints the content of the selected window.
The Print via Excel function embedded the selected window into a selected Excel sheet together
with data from the SpecSheet. This updated Excel sheet may be printed out directly or with a
preview before.
Print via Print manager opens a window with additional printing options.
Before printing the background color of the window changes to white color to save printer
ink. This option can be controlled in the Analyzer options dialog.

2.11.3 Management
The name of the file containing the FFT settings may be renamed or deleted inside the management
editor that is accessed from the main menu Functions ⇒ Spectral analysis ⇒ manage settings. The
editor shows also the name of the used phase settings files.

2.11.4 Properties
The FFT properties include options to control FFT window and graphics handling. This panel is accessed
by selecting “Properties” in the context menu (right click on the FFT plot).

2.11.5 Examples
Example 1
In this example you will learn to show the bike front suspension chattering through a FFT analysis. For
this the front suspension channel is selected. One single data series of 512 measured values will be
analyzed.
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In the main menu select Functions ⇒ Spectral analysis ⇒ Create new.
Enter a name for the spectral analysis and click on <OK>.
On the panel settings select the channel “@Front_Susp -> Front Fork”, a FFT depth of 512, the Single
source option (…) as shown on the figure below.

The FFT chart is created as shown below.

Example 2
In this example you learn how to show bike front suspension chattering. All visible data inside the moving
window of the front suspension channel are analyzed. The FFT depth is 512. The result is displayed in
a waterfall chart.
In the main menu select Functions ⇒ Spectral analysis ⇒ Create new.
Enter a name for the spectral analysis and click on <OK>.
On the panel settings select the channel “@Front_Susp -> Front Fork”, a FFT depth of 512, the waterfall
source option as shown on the next figure.
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The waterfall chart is created right away.

2.12 Acceleration table / Dynamic test system (DTS)
This function is accessed through the main menu Functions ⇒ Dynamic tests or directly through the
keyboard short cut <Alt> + <B>.
Dynamic test system software module generates report from:





ELX - "Elk test", slalom and lap times
ELA - elasticity test
MFDD (mean fully developed deceleration) - braking test
ACC - acceleration test

You will get detailed information in the manual dedicated to this topic. This topic is also well covered on
the Help that can be accessed by right clicking on the main DTS panel.
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3 General functions and topics related to Analyzer
3.1

Function related to the (user defined) Quick bar

The Quick bar is on the right side of the screen. If the window is not visible, it can be made visible
through the keyboard short cut <Alt> + <W> or from the main menu View ⇒ Quick bar.

Procedure for adding user defined items from the menu to the Quick bar:
Select an item from the menu. Right-click on the item and confirm the question “Add to user defined
menus?” with <OK>. A link to the selected menu item will be added in the Quick bar.
Sorting and deleting items of the Quick bar
To modify the Quick bar, click on an entry with the right mouse button. You then have the options to
move the entry up or down, remove the entry or remove all entries.

3.2

User management

The user management window is accessed from the main menu Settings ⇒ User management.
Working as different users may be interesting, if the computer is used by different people or if you are
working in various racing series or have different vehicles to support.
A “user” (user profile) includes all user settings, for example channel lists, channel groups, templates,
etc. An unlimited number of users may be created and managed by the supervisor user.
Users can be deleted, renamed and their settings exchanged with other users.
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3.3

Phases

Subset of measured data defined by Phase conditions.
Phases are used to filter the data. For example you are only interested in the data of the
fastest lap. Or you want to have a look at the current selection, but only while braking or on
full gas. This functionality is very helpful to filter the data for min/max tables or other
analyzing modules.
A data subset (= phases) is defined by the combination of one or more phase conditions.

3.3.1

Definition

Phases reduce the amount of data analyzed. Options from the data filtering are for example by
lap/selection, time or distance range, or channel value range (see panel below).
By using phases the data are filtered and only the filtered data will be taken into account for other
analyzing modules such as Min/Max table, histogram…
Phase conditions can also be applied to signals in the Analyzer without being related to a specific
analysis module. To set the phases for the “general” Analyzer select from the main menu Measurement
⇒ Phases definition (Shift + P). In this case the sections, when the conditions are fulfilled, are indicated
on the top side of the overview window:

To define the phases, select “Lap/Selection”, “Range” or “Channel dependent” with a double-click and
set the filter as needed.
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Preview
The phases defined by a single phase condition can be shown via button <Show>.
The phases defined by the combination of all chosen phase conditions can be shown via button
<Preview>.

Deletion of small phases
Deletion of small phases or small gaps makes sense, especially when a phase condition of type
“Channel dependent” is used. A very noisy signal which is varying around the chosen limits could create
many very short phases until finally its values are constant between the limits. Those short phases may
disturb the analysis, therefore optionally they may be ignored.
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Phase conditions
Logic Type:




“AND”: Data is selected when all of the selected conditions are true.
“OR”: Data is selected when (at least) one of the selected conditions is true.
“Create Events”: Each condition creates several data points.

Available Conditions:
There are 3 different condition types:




Lap/Selection
Range
Channel dependent

Several of them can be selected and combined via the logic type.
Active Conditions:
Those are the phase conditions you defined.
Delete Phases:
To reduce the number of resulting phases you can eliminate very short sections as well as small gaps
inside of the sections.
Create Events:
Only selectable when logic type "Create Events".
Choose whether to accept starts or ends of the events created by this phase condition.
Show Remove:



<Show>: Examine the resulting data selection (=phases) defined by this phase condition.
<Remove>: Remove this single phase condition from your set of active conditions

Phase Laps:






“Current lap”: Selects from beginning to end of the current lap.
“Current selection”: Selects which is currently shown in Moving window.
“All laps without in/out”: Selects all laps which are not in/out laps.
“Selection in all laps without in/out”: Like "current selection", but applies to all laps without in/out.
“Fastest lap”: Like current lap, but uses fastest lap.

Follow selection:
Applies to min/max table and XY plot. The phases are updated immediately when:



“Current selection” is used.
Selection in moving window is changed.

Definition of in/out laps:
A lap which differs more than x% in time or distance from the best lap is treated as an in/out lap.
Phase Range:




Define a range (in meters or time).
Enter manually or get various input by clicking on arrow buttons.
"Lap based" creates many ranges (one for each lap).
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Phase Channel:
Choose a channel and its lower/upper limit.
The resulting phases cover all sections where this channel's values are between the chosen limits.

3.3.2

Usage

Phases are used in min/max tables, XY plots, track mode or histograms. Additionally phases can be
displayed inside the moving window.
The phase conditions are saved and can be re-used later. It is possible to use the phase conditions
which have been defined e.g. for an XY-Plot in another context, for example in a Histogram.

3.3.3

Examples
Example 1

You want to examine data of the fastest lap, where the RPM was higher than 10500 and the throttle was
open. You have to select:





Logic type “All conditions (AND)”.
A condition of type Laps and subtype “Fastest lap”.
A condition of type Channel dependent with channel “RPM” from 10500 to 20000 (should be
enough).
A condition of type Channel dependent with channel “Throttle” from 20% to 110%.

As a result, all phases are displayed that fulfilled the condition “fastest lap where RPM and throttle are
within specifications”.
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Example 2
You want to look at data of two certain corners. You have to select:




Logic type “At least one condition (OR)”.
A condition of type Range where you enter the position of the first corner by selecting the
position range in meter.
A condition of type Range where you enter the position of the second corner by selecting its
position range in meter.

As a result, all phases are displayed that fulfilled the condition “Position of first and second corner”.

If you´ve selected “Lap based”, it will use the first and second corner of each lap.

3.4

Print (via Enhanced Meta File)

Vector format provides powerful features to utilize the high printer resolution.
The print function which is available in all Analyzer graphic windows uses EMF (Enhanced Meta File)
techniques. EMF is a Windows vector format that takes advantage of the high printer resolution when
printing lines. EMF exported as file may be scaled without loss in image quality to any size e.g. in
Microsoft Word or Excel (see example).
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Example: A Track mode graphic in EMF format in regular screen size

A zoomed section of the same window:

3.5

Print report manager

The Print report manager can be accessed via main menu as well by any graphic window
(Functions ⇒ Print report manager <Alt> + <P>).
This print report manager allows the user to configure the page. All current Analyzer graphic windows
may be selected and placed freely (in size and place) on the page. Additionally, SpecSheet entries and
complete groups may be selected as well as measurement specific data, own free texts or images. In
tab “Editor” you can define your page layout and in tab “Preview” you can have a look at the page.
The graphics are printed with high printer resolution instead of screen resolution.
The function "Get current Analyzer windows" retrieves the current screen from Analyzer and places the
individual graphic windows on the print report page.
An image of the current print manager page may be saved to disk or clipboard.
Also the “Print via Excel” functionality is available.
The print manager setting can be saved to disk to re-use it later.
For detailed information you can open the context sensitive help module. To do so press
the button <F1> in the opened print report manager window

3.6

Time Diff

Virtual channel which shows the time win/loss by lap
The Analyzer generates automatically some virtual channels, which are available at run time, as soon
as more than one measurement is loaded. These channels are “Time diff”, “TDiff window”, “Meter diff”,
“MDiff window” and “Win change”.
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The virtual channels contain the time/distance difference of one measurement's lap compared to another
measurement's lap1. This difference is cumulative over the entire lap.
Changing the current lap of one of the two measurements will automatically update the Time diff channel.
Each measurement has its own Time diff channel which is relative to measurement 1. Therefore the
Time diff channel of measurement 1 is always zero because it is relative to itself.

3.7

TDiff window

Virtual channel which shows the time win/loss on the time/distance range selected in the moving
window.
The virtual TDiff window channel displays the time difference between two loaded measurements which
are both currently visible in the Moving window. The time difference displayed refers to just that selection
visible in the Moving window and is not cumulative over the full lap.
Changing the selection visible in the Moving window will automatically update the TDiff Window channel.
Each measurement has its own TDiff window channel which is relative to measurement 1. Therefore
the TDiff window channel of measurement 1 is always zero because it is relative to itself.

3.8

Reference laps

A reference lap is a user defined lap which is extracted from the measured data. It is handled like a
normal measurement, but has wrap-around functionality to allow comparison with regular laps. The
reference lap can be loaded and saved from the main menu (File ⇒ Load Reference Lap and File Save
as Reference lap)

3.8.1

Creation

Select a lap from the measurement and save this lap as reference lap.

3.8.2

Comparison of the reference lap with laps from a measurement

Load a measurement and a previously saved reference lap of the same event. The reference lap is
converted into a reference measurement. That means that the reference lap is twice in that
measurement and it is used in a loop. This allows to compare the reference lap with any lap of the
loaded measurement.

3.9

Export

With the 2D software you are able to export any data in different data types (for example CSV, ASCII,
2D measurement, Excel, etc.). You can modify the setting to export only a selection of data. This

1

It can also be another lap of the same measurement.
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selection could be of length (for example fastest lap, current selection, defined conditions, etc.) or of
channels or a combination of both.
To create a new export setting start the Analyzer and select File ⇒ Export (Alt + E) ⇒ Create new

Enter a name for the new export setting and confirm with <OK>:

In the next window you define your export settings.
You start with the export type: Select the format the data should be exported to from the drop-down list.
Depending on this the options to define the export settings will differ.
By exporting the data to a new 2D measurement, you can modify your measurement to
your needs. For example you can select only the “driver relevant” channels, such as RPM,
speed, gear, throttle, brake, etc., and set the phases to use only the fastest lap.
This smaller measurement you could use for a live export to give to your driver.
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Select the settings for your export:







Export type: Select the export´s type from the drop-down list
Storage location: Set the folder, where your export will be saved. You can choose between “Use
event folder” (then it will be saved in the current event folder) or select any folder. Please have a
look at section 8.1 for available folder placeholders.
Export´s file name: Enter the naming elements (placeholders) to define the file name, for example
“X_<MesName>”. Please have a look at section 8.2 for available naming elements (placeholders).
Separators: Depending on the export type you can select the separators.
The separators´ settings are global. This means if you change them, they will be
changed for all export settings.





Channel settings: Select the channels you want to export and their sampling rate.
SpecSheet groups: Select the SpecSheet groups you want to export.
Phases: Set the used phases for the export. If you don´t use phases, everything will be exported.
If you want to use phases (for example the fastest lap), click on <Phases> and define your settings.
At the bottom of the export defining window you can see which part of the measurement will be
exported:
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Confirm the changes by saving the settings (<Save Export settings>) or exporting the data
(<Export>).

3.10 Live Export
The live export function is accessed from main menu File ⇒ Live Export
It is a special export function that creates a stand-alone executable (.exe) containing the data and a
data reader. This executable is named by appending “LiveExport_”, the event and the measurement
names. For example LiveExport_BIKE_DEMO.exe is an executable that contain the data of the
measurement “Demo” of the event “Bike”. This executable contains also a version of the Analyzer having
only the functions necessary to process the data in the executable.
You can run this stand-alone .exe-file on any (Windows) PC even without a 2D Race version installed
or licensed. After closing the Analyzer all temporary files are automatically removed.

3.11 Screen Export
This function is accessible from the main menu File ⇒ Screen export.
It is a special export function that creates a 2D measurement which contains the section of the channels
of the active measurement as selected in the moving window.
When the screen export is done, the measurement is saved in the typical 2D measurement format:
.MES-folder. The new .MES-folder is compressed (zip format). Therefore it can be sent easily per e-mail
to another 2D user.

3.12 Cut measurement
This function is accessible from the main menu File ⇒ Cut measurement.

There are 3 functions to cut a measurement:
1. Delete to marker
2. Delete from marker
3. Trim both markers
To use the two first functions (Delete to marker/Delete from marker), one marker 2 must be set in the
moving window.
This kind of marker is set by clicking on the moving window while being in measuring mode.

2

This marker is not a user defined marker.
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1. Delete to marker
The data between the marker and the end of the
measurement is saved. Optionally the first part of
the measurement can be saved under another
name.

2. Delete from marker
The data between the start of the measurement
and the marker is saved. Optionally the last part
of the measurement can be saved under another
name.

3. Trim both markers
This function is only available, if two markers are
set.
The data between those two markers is saved.
The data outside the markers are lost.

3.13 Calculation file manager
The calculation file manager is accessible from the main menu Function ⇒ Calculation files, or by
keyboard shortcut <Alt> + <N>.
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Administration of calculation files for the 2D program CalcTool. The program CalcTool is documented
in a separate user manual3. Please refer to this manual for more information about cal-files.
CalcTool is part of the 2D software. It is used to create calculated channels from channels measured
and recorded by a 2D data acquisition system. CalcTool is called automatically from the communication
software WinIt to linearize non-linear channel data. You can define the channels to be calculated by
writing a so called cal-file, which is a simple text file containing the instructions for the calculation.
Cal-files may be found/saved in different folders:





Data root folder: The folder containing your event folders, i.e. RaceData
Event folder: The folder of your currently selected event, i.e. Jerez.16
Measurement folder: Your currently selected measurement folder, i.e. FP1-MK36-01.MES
Software folder: Folder “CalFiles” inside your Race software

Click on “New” and “Edit” to respectively create or modify a cal-file. The cal-file editor incorporates
features like syntax checking and code completion. Code completion is a functionality that helps the
user when they are developing a cal-file. Functions and channel names are proposed to the user, exactly
when they have to be set.
To run a selected cal-file click on “Calculate”. After successful execution, the measurement will be
reloaded.
The button <Configurator> starts the AutoCalc-configurator, where you can modify the list of
automatically executed cal-files directly after the download. To execute all cal-files selected in the
AutoCalc-configurator, click on button <Run AutoCalc>.
If you are working with special channels in your cal-files, you can check and define those by clicking on
button <Special channels>.

3.14 Real time player (signal value to audio signal and force feedback converter)
The real time player allows the playback of up to three recorded channels. It converts their values into
a sound that can be played on the PC´s speakers, the soundcard or a force feedback controller such as
a special joystick. This function is accessible by right clicking on the moving window.

3

The manual can be downloaded from: 2d-datarecording.com/en/downloads/manuals ⇒ CalcTool
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If the option “Loop” is enabled, the playback will be repeated when the end has been reached.
If the option “Stay in selection” is disabled, the content of the moving window will follow the section of
the signals played back. A dotted vertical line visualizes exactly the position of the signals being played.
The position at which the playback starts is selected among the following options:





Start of measurement
Start of current lap
Start of current selection
Center of the current selection

The playback speed can be the normal speed, i.e. the speed at which the signals have been recorded,
the half or the double of this speed.

3.15 Video playback
With the video playback function it is possible to play a video that has been recorded along with the
signals. The accepted video formats are .avi and .mpeg. The video is imported either from the main
menu Function ⇒ Video or Plugins ⇒ 2D Video Functions.

3.16 Templates
Storage of desktop layouts of the Analyzer windows.
A template contains the position and size of all Analyzer windows visible on the desktop. This desktop
layout can be saved under a unique name to disk in a so called template. Templates are used to restore
the windows positions and sizes of the Analyzer.
Save your current Analyzer windows layout into a template by clicking on the template button in the
main toolbar. Select “Save as” and accept the name or enter an own name.

Restore a previous saved template by clicking on the template button in the main toolbar
and selecting the desired template.
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Alternatively, you can save and manage templates from the main menu Settings ⇒ Templates:

3.17 Quick Key
Structured list of keyboard shortcuts assembled into macro functions
The quick key function allows execution of common functions via keyboard shortcuts. Items like
channels or groups can be added, removed or replaced quickly.

The quick key window is opened by pressing the key < + >, < - > or < # >. The progress indicator
indicates how long the quick key window is open and therefore how long the macro keyboard shortcut
can be entered.
For example: Press < + > followed by < C > and <Enter> to open the list of channels.
1. The type: Add, remove or exchange
a) Key < + > or < Ins > adds something
b) Key < - > or < Del > removes something
c) Key < # > exchanges something
2. The category (what to handle)
a) Key < R > means a run (measurement)
b) Key < G > means a group
c) Key < C > means a channel
d) Key < A > means an area
e) Key < L > means a lap
f) Key < O > means the overlay of another lap
g) Key < T > means a template
h) Key < Z > means zooming of the selection in the Moving window
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3. The item to work with
a) Run (measurement): the item key represents the measurement to remove or exchange
b) Group: the item key represents the short key of a group
c) Channel: the item key represents the short key of a channel
d) Area: the item key represents the short key of a group to handle in an area
e) Lap: the item key represents the lap number to jump into, "F" means fastest lap
f) Overlay lap: the item key represents the lap number to load and overlay, "F" means fastest lap
g) Template: the item key represents the short key of a template to apply
h) Zoom: the item key represents the factor to zoom in or out, "L" means whole lap
After pressing the type key the quick key window opens. After a short period, if there is no
keyboard input, it will close automatically.

3.17.1 Examples
Action
Switch off channel “V_Front” (assumed V_Front has short key “F”):
Switch on group “Engine” (assumed Engine has short key “E”):
Switch off group “Engine” and replace by group “Suspension” (assumed Suspension
has short key “S”):
Compare current lap with fastest lap by overlaying it:
Zoom in twice:
Zoom out whole lap:

combination
-cf
+ge
#gs
+of
+z2
-zl

3.18 Quick Channels
Open the quick channels window by clicking on the arrow right of the logger icon in the tool bar, then
select “Channels”.

The quick channels window lists all channels of the active measurement.
The channels may be shown either listed one after the other or grouped by channel types (digital, analog,
CAN, calculated or virtual).
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Channels listed one after the other

Channels listed and grouped by types

The visibility of a channel may be switched on or off by clicking on it. Nevertheless, a mouse click will
not only toggle the visibility but it will also close the window. To toggle the visibility of channels without
closing the window, press <CTRL> while clicking on the channels with the mouse. The window will stay
open thus allowing to switch several channels one after the other.
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4 Tutorials
Available tutorials:







Save current desktop layout
Show measured data over distance
Perform grouping of channels
Show Time Diff (win or loss)
Display a Track mode
Show phases in Moving window
For detailed information start the 2D Analyzer and select from the main menu “Tutorials”.
Tutorials are only available for 2D software licensed at the level “System” or higher.

Select a tutorial and perform it step by step
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5 Options specific to the Analyzer
Each user of the Analyzer has his own options set.
The settings of the Analyzer are accessible from the main menu Settings ⇒ Options or with the keyboard
shortcut <F9>.
In the settings window there are several tabs. The tabs group options. The options found in each group
are explained below.

5.1

General



Meters lap relative
X axis scaling in distance plot starts at 0 at the current lap's start.



X-axis scaling starting with 0
X axis scaling starts at 0 at the start of the selection in the Moving window.



X-axis scaling in time format
Set X axis to be a time scale.



Measuring values window jumps when under cursor
With this option enabled a movement of the cursor in Measuring mode near the measuring values
window causes the window to jump out of the way to the other side of the screen.



Center by cursor (Shift+C) moves cursor to center position also
If you use the shortcut <Shift> + <C>, the position where the cursor is located at that time will be
put in the center of the moving window.



Automatically convert old measurements
A measurement which is saved in the old data format version V1 (*.par) will be converted into current
2D measurement format (V3). The current format handles all files of a measurement together in one
folder with .MES extension.



Activate overview when toggling active measurement
When a measurement is activated its corresponding overview window will be shown and made
active.
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Reload measurements without confirmation
Skip query when reloading a measurement after fundamental changes made to the data, for
example through the execution of cal-files.



Grid in Moving window
Controls whether a scaling is shown for the first displayed scaling only or for all visible scales.

5.2

Program start



Template
The template selected will be applied to the desktop layout when the Analyzer is started.



Use last session desktop
The desktop layout of the last Analyzer session is applied.



Selection/Zoom full lap
Choice whether to show a complete lap at Analyzer start, together with the option about which lap
to display.



Plot
Selection of the default setting of the moving window´s x axis: distance or time plot.

5.3

File load



Synchronize new loaded measurements
If a measurement is already loaded, each subsequently loaded measurement is placed at the same
position on the track.



Switch to distance plot
When loading another measurement, the Analyzer plots the signals as a function of the distance to
make comparison with other measurements easier.



Show channel "Time Diff" when second file loaded
After loading a second measurement, the virtual Time Diff channel is created and assigned to the
first measurement's channels.
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Show channel "Time Diff window" when second file loaded
After loading a second measurement, the virtual TDiff Window channel is created and assigned to
the first measurement's channels.



Run lap checker if event on closed track
Depending on the track settings (closed track or not), each time a measurement is loaded that has
not been checked before, the lap checker wizard will check track length and lap triggers.

5.4

Colors



Each measurement has its unique color by which it can be identified.
The color selected is applied to all channels of the measurement in the Moving window. This is very
useful when more than one measurement is visible.



Print/White background
Before printing a window its background color or complete color scheme will be switched to a more
suitable white background to save the amount of printer ink.



Channel colors/Saturated channel colors
Instead of displaying all channels in their measurement colors this option causes a slight color
saturation to help separating the channels.

5.5

Key assignment
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Cursor keys move...
Choose whether pressing the cursor keys move the curves or the selection window.



Trackball mode
An option to reposition the mouse cursor after moving the selection. This makes the use of a
notebook's trackball easier in Moving window.



Delayed drawing
This option controls drawing of channels in Moving window: moving the selection with cursor keys
left/right will just draw the active channel until key released, after that the full graphics will be drawn.
This helps fine tuning of the selection on slower computers.

5.6

Effects
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6 Help for controlling the Analyzer with the keyboard
6.1

Complete list of shortcuts

Shortcut
<1-9>
<ALT + 1-9>
<CTRL + 1-9>
<A>
<C>
<M>
<P>
< SHIFT + P >
<S>
<T>
<V>
< SHIFT >
< CTRL + S >
< SPACE >
< ENTER >
< SHIFT ENTER>
<CTRL + ALT + H>
<CTRL + ALT + B>
< Escape >
<+/-/#>
< Home >
< Page Up >
< Page Down >
< CTRL + Home >
< SHIFT + Home >
<SHIFT + CTRL + Home>
< Back Space >
< ALT + Z >
< F1 >
< CTRL + F1 >
< F9 >
< F10 >
< F11 >
< ALT + L >
< ALT + S >
< ALT + E >
< ALT + M >
<X>
< ALT + F1 >
< ALT + F3 >
< ALT + F5 >
< Alt + P >
< ALT + U >
< ALT + N >
< ALT + I >
< ALT + B >
< ALT + Q >
< ALT + V >
< ALT + W >
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Action
Activate the measurement in the “Moving window”
Show the “Overview window” for the measurement <1-9>
Show or hide the measurement <1-9> in the “Moving window”
Show the “Overview window” of the active measurement
Show / hide the “Circuit window”
Show / hide the “MultiCircuit window”
Shows the phases in the “Moving window”
Edit the phase conditions for the “Moving window”
Change the x-axis unit to distance
Change the x-axis unit to time
Link measurements, when more than one loaded
Invert “link status” when moving several measurements
Synchronization of measurements
Start measuring mode
Start measuring mode for the active measurement only
Start measuring mode for the active measurement in channel colors
Show measured values in hex mode
Show measured values in binary mode
Terminate the “Measuring mode”
Activates the “QUICK KEY” key function
Move to the beginning of the current lap
Show next lap
Show the previous lap
Move to the fastest lap
Select the entire lap
Select the entire section
Undo last selection
Define the zoom factor
Activates the context sensitive help
Show / hide hint window
Show the “Options” window
Access the main menu of the analysis tool
Toggle the active window’s state between “normal” and “maximized” size
Show the lap times of the loaded measurements
Show the section times of the active measurement
Export the measurement data
Show the list of available “Min/max table” settings
Show the list of available “Track mode” settings
Show the list of available “Histogram” settings
Show the list of available “FFT” settings
Show the list of available “XY-plot” settings
Start print report manager
Show a list of all available channels
Start the “Calculation file manager” – Administrate your cal-files
Start the SpecSheet module (=2D data management tool)
Show dynamic test module "DTS"
Enter a comment for the active measurement
Show a complete current active windows list
Show / hide “Quick bar” for access to common used functions
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Shortcut
< CTRL + ALT + Q >
< CTRL + C >
< CTRL + E >
< CTRL + R >
< CTRL + G >
< SHIFT + S >
< SHIFT + T >
< ALT + O >
< CTRL + O >
< CTRL + M >
< CTRL + ALT + S >
< CTRL + P >
< ALT + R >
< CTRL + ALT + D >
< CTRL + W >
< CTRL + L >
< CTRL + D >
< CTRL + T >
< ALT + X >

6.2

Action
Save a screen shot of the desktop
Copy active form into clipboard
Exchange the active measurement with another one
Remove the active measurement
Show the channel list with the “Groups” tab selected
Edit special channels
Edit track settings
Load another measurement of the current event
Load another measurement
Link to Google Earth
Swap (interchange) 2 loaded measurements
Show properties of the currently active window
Restore window positions using the current template
Display measurements in moving window vertically separated
White background
Light (grey) background
Dark (black) background
Use individual (template) color scheme
Terminate the program Analyzer

Keys active in the “Moving window”

Shortcut / Mouse
Mouse: Left button
Mouse: Double click
<s>
<t>
<1>-<9>
< ALT 1 > - < ALT 9 >
< CTRL + HOME>
< SHIFT + HOME >
< CTRL + ALT + F >
< ALT + Z >
< CTRL + ALT + M >
< F11 >
< CTRL + C >
<g>
< CTRL + ALT + D >
< CTRL + P >

2D Analyzer

Action
Offset moving
Start measuring mode
Change to Distance plot (x-axis unit = distance)
Change to Time plot (x-axis unit = time)
Activate measurement 1-9
Show overview
Fastest lap
Entire lap
Open filter options for the currently active channel
Define the zoom factor
Show magnifier window
Maximum / Restore window size
Copy the graphic content of the moving window to clipboard
Show / hide grid lines
Display measurements vertically separated
Show properties of the currently active window
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6.3

Keys active in the “Moving mode” & “Measuring mode”

Shortcut / Mouse
Moving mode
< SPACE >
< ENTER >
< SHIFT + ENTER >
< Mouse left button > On
vertical channel scaling
Measuring mode
Mouse: Left button
Mouse: < CTRL > + left
button
Mouse: Left button in
measuring values number
Mouse: Left button on
channel name in
measuring values
Cursor left / right
< CTRL > + cursor left
< CTRL > + cursor right
< SPACE >
< ESC >
< "<" or ">" >
<Z>
<CTRL + ALT + I>
< CTRL + Z >
< CTRL + V >
< SHIFT + L >
< ALT + Y >

2D Analyzer

Action
Start measuring mode
Start measuring mode for the active measurement only
Start measuring mode for the active measurement in channel colors
Arrange the channel displayed vertically
Set left or right marker
Select the active channel
Select the active channel
Toggle channel´s visibility
Move the cursor that is anchored on the active channel. The cursor is at
the crossing of two dotted lines.
Set left marker
Set right marker
Stop measuring mode
Stop measuring mode
Toggle between channel to set the active one
If 2 markers have been placed : Zoom by markers
If 2 markers have been placed: Interpolate values for the visible channel
If 1 marker has been placed: Redefine offset of the active channel
If 2 markers have been placed: Redefine the formula the of active
channel
Add lap trigger at mouse cross position
Add section at mouse cross position
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7 Glossary
Expression
Acceleration table

Explanation
A table with acceleration, deceleration and elasticity data. This table is
calculated from the measured data and displayed in an extra window.
Active channel
The channel in which the two dotted lines are crossing when the mouse
is moved in the measuring mode. Some special measuring can be
performed on this channel. The active channel can be set separately for
each loaded measurement.
Active measurement
The measurement in foreground on which most functions are applied.
Every measurement loaded can be activated.
Area
Sub window in the moving window which contains channels of a group.
More than one area may be displayed.
Calculation file
A file (*.cal) with calculation formulas for channels. If selected in the
AutoCalc configurator, the cal-files can be executed automatically after a
download.
Channel
Each (sensor-) signal whose data is downloaded results in a channel of
the measurement.
Channel sampling rate
The recording frequency of a single channel.
Chassis
External module to show the chassis geometry. Chassis geometry can be
outputted either graphically or in text form depending on the software
license level.
Circuit window
A window which shows the track map with the current selection of the
active measurement highlighted. The circuit window may be turned off or
on.
Clipboard
A Microsoft Windows data container which allows exchange of text or
graphic between programs.
Color channel
The selection of a channel for graphical purposes to define a 3rd
dimension. The physical values of the channel are mapped to colors.
Color scheme
A bundle of suitable colors for one window. The color scheme is applied
when the Analyzer is restarted.
Comment of measurement A free editable text stored together with the measurement. This text may
consist of several lines and can be printed along with any window.
Distance plot
The plotting of the measured values over distance (X-axis in dimension
“meter”). The distance is calculated internally by integration of a speed
channel.
Export
Function to extract parts of a measurement. Selection criteria are time
range and the channels list. Different formats are supported such as
Microsoft Excel or CSV.
Export of settings
A function to save Analyzer settings into a specific folder. This allows
interchange of settings with another 2D software user.
Grid
A graphical aid with horizontal and vertical lines. It is available for each
visible window where signals are shown.
Group
Definition of a group of channels which are handled together. This
grouping of channels allows a fast topic related analysis. A topic may be
something like “engine” or “suspension”.
Histogram
A histogram is a graphical representation of the distribution of numerical
data. It is an estimate of the probability distribution of a continuous
variable.
Ideal lap time
The sum of best section times.
Joined
switching
of Option to switch a channel's visibility together in the moving and overview
channels
window.
Lap trigger
A marker which shows the position of the lap time signals. Information of
lap triggers are downloaded together with channel data. Lap triggers may
be modified manually.
2D Analyzer
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Expression
Link measurements
Main sampling rate

Measuring cross
Measuring mode

Min-/Max table
Moving mode
Moving window

Overlay of lap
Overview

Phase condition
Phases

Quick key window

Real Time player

Reference lap

Route

Saturated color

Scaling

Section

Segment

Short key

2D Analyzer

Explanation
A function to move all loaded measurements together in the moving
window.
The recording frequency of the data logger from which the measurement
was downloaded. The channel sampling rate is equal or lower than the
main sampling rate (factor 2, 4, 8, 16, 32, 64, 128).
In measuring mode, the measuring cross is built by two dotted lines
defined by the active channel´s value and the position of the cursor.
An analyzing mode which shows numerical values of the visible channels
at the position of the measuring cross inside the Moving window.
Alternative state to the moving mode.
A table with the minimum/maximum/average values of channels per lap.
A subset of the data analyzed may be defined using phases.
The selection inside Moving window can be moved with the mouse.
Alternative state to the measuring mode.
The main analyzing window with channel value (signal) curves of the
selected part of the measurement. The selected part of the measurement
can be zoomed in and out or moved.
A function to compare several laps of one measurement or with another
measurement. Up to 9 measurements can be loaded and overlaid.
A window which displays some signals (channel values) of the whole
measurement range with a reduced resolution. Each measurement
loaded has its own overview window.
A logical condition to define a subset (Phases) of the measured data.
Several Phase conditions can be combined with “AND” or “OR” operator.
Phases are a combination of phase conditions combined by the operator
“AND” or “OR”. They are used to filter the data before being used for
different purposes like Export, Histogram, XY-plot etc.
When this window is open, it is possible to achieve common tasks with a
series of keyboard shortcuts. For example, channels or groups can be
added, removed or exchanged.
The real time player reads signals data, converts the data in a sound
and/or a feedback force. Playback output may be the PC-speaker, the
sound card or a force feedback joystick.
A user defined lap which is extracted and saved from the measured data.
It is handled like a normal measurement but has wrap-around functionality
to allow comparison with regular laps.
2-dimensional data which contains driven position. This allows to draw a
XY-plot which shows the geographical path on which the measurement
has been made.
Saturation is used to create a 3rd dimension by changing locally the color
as a function of the channel values. For this purpose a color channel is
used that defines how the channel values are converted into a color.
Text area besides graphics to give information about physical values at
certain steps. One of the most important scales is the time resp. distance
scaling for the x-axis in moving and overview windows.
A track can be divided into different sections. Most of the time this is done
by GPS coordinates or other recorded section triggers. It can also be
divided by the driven meters while analyzing the data. The definition of
the sections is used for the section times table.
A track is separated in two kinds of segments: straights and corners. This
is used for the Track mode window, where you can display the minimum,
maximum or average values of a selected channel for each segment.
A short key is a (user-defined) keyboard shortcut. This enables fast
access to different functions or the quick key window and its functions.
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Expression
SpecSheet

Special channel

Synchronize
Template

Time plot

Time diff

TDiff window

Trackball mode
Track length

Track mode window

Track offset

Track tolerance
User defined markers

User management

Valid lap

Video link

Visible windows
Visibility of measurement

2D Analyzer

Explanation
The database with additional information about each measurement.
SpecSheets are used for cross-analysis. Normally it is opened by the 2D
program SpecView.
A channel with defined intention which is used for internal functions. Each
channel of a measurement can be assigned to any one of the special
channels. The list of special channels applies to all measurements of the
Event.
Function to place the other measurement's selection close to the active
measurement's selection in their respective laps.
The definition of desktop layout of several windows. The desktop layout
may be saved inside a template and restored later by choosing this
template once again.
The display of the measured values over time (X-axis in dimension
"time"). Always on in Overview windows, but selectable in the Moving
window.
A virtual channel which shows the time win/loss of one measurement's
lap compared to another one's lap. The Time diff channel is available only
for the measurement 1. The second measurement to compare is
selectable.
A virtual channel which shows the time win/loss of one measurement's
selection compared to another one's selection. The TDiff window channel
is available only for the measurement 1. The second measurement to
compare is selectable.
An option to reposition the mouse cursor after moving the selection. This
helps the use of a notebook's trackball in Moving window.
The length in meters for one lap of a track. All laps of a measurement
whose lap length differs from the Track length not more than Track
tolerance are treated as Valid laps.
A graphical display of one lap with the inscription of defined channel
values at certain points. The inscription of the channel values is organized
in rectangled markers which may be placed freely.
The distance in meters between lap trigger position and start/finish line of
the track. This value has to be defined precisely to create a correct
relationship between the measured data and the track map.
The percentage of the lap length to Track length deviation which defines
a Valid lap.
A set of markers placed by the user to highlight some user defined
positions in a measurement. It may be used to show defined channel
values at certain points at the Track mode window.
The management of several Analyzer users with individual channel, group
and options settings. The creation of more than one user causes a login
prompt at program start.
A lap whose calculated lap length differs from the Track length not more
than Track tolerance. If a lap is not valid several functions and displays
are not available for this lap.
An external module to play and synchronize a video footage along with
the measured data. The video link function is available depending on the
licence level.
A list of all Analyzer windows which are currently open. Each entry
represents one window and may be closed or forced to foreground.
A function to temporary hide the data of a loaded measurement. This is
helpful to focus on another loaded measurement by reducing visual
information.
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Expression
Window list
Wizard
XY-Plot

Zoom

2D Analyzer

Explanation
A window with buttons linked to the most common functions. It may be
closed permanently to gain screen space.
An "intelligent" external module with an extra specialized purpose.
Wizards are used mainly to create additional calculated channels.
A function to show the relationship of 2 channels graphically. XY-Plots
may include several measurements and use a Color channel as 3rd
dimension.
A function to enlarge or reduce the data selection in the Moving window.
Zoom functionality can be achieved via the Quick key window, keyboard
or mouse.
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8 Appendix
8.1

Storage location placeholders

To save the exports in the correct place, there are some defined placeholders to use for different storage
locations:
o
o
o
o
o
o

8.2

<DriveName=volume>
<TempDir>
<DataDir>
<EventDir>
<MesDir>
<RaceDir>

temporary directory
current data directory, which is selected in WinARace
current event folder
current measurement folder
Race program data

Naming element placeholders

To create a systematic name for the export, there are different naming element placeholders available.
This enables you to create different names without changing the settings.
o
o
o
o

<EventName>
<MesName>
<LapNr>
<HED=section.ident>

name of event
name of measurement
number of current lap
entry of the SpecSheet, for example: <HED=BIKE.Chassis>

With the last naming element (<HED=section.ident>) you can call every information stored inside the
SpecSheet.
Examples:
1) You want to do an Excel export of the data of a min/max table and you defined the name to
export as “MM-<EventName>-<MesName>”.
Your event is named “Aragon.16” and the corresponding measurement is named “Test-VK4805”. Your Excel export file will be named as MM-Aragon.16-Test-VK48-05.xlsx.
If you use the same export setting with a measurement named “Race-NA31-01” of event
“Assen.15”, then the export file will be named MM-Assen.15-Race-NA31-01.xlsx.
2) You want to export the data of the fastest lap into CSV format and you defined the name to
export as “<EventName>-<MesName>-<HED=Info.Driver>-Lap_<LapNr>”.
Your event is named “N24h.16”, the measurement´s name is “Race-4711L-01”, your SpecSheet
has the entry Driver=KRO in group “Info” and the fastest lap is lap 36. Your CSV export will then
be named N24h.16-Race-4711L-01-KRO-Lap_36.csv.
If you use the same export setting and your event is named “Hockenheim.16”, the
measurement´s name is “QP-B1-#99-03”, the SpecSheet has the group “Info” with the entry
Driver=DC and the fastest lap is lap 3, then the created CSV export file will be named
Hockenheim.16-QP-B1-#99-03-DC-Lap_3.csv.

2D Analyzer
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